June 12, 2011

RESET PASSWORD SWITCH CATALYST

Procedure with Password Recovery Enabled

If the password-recovery mechanism is enabled, this message appears:

The system has been interrupted prior to initializing the flash file system. The following  commands will initialize the flash file system, and finish loading the operating system  software: 

flash_init 
load_helper 
boot 

Step 1 Initialize the flash file system:

switch: flash_init 

Step 2 If you had set the console port speed to anything other than 9600, it has been reset to that particular speed. Change the emulation software line speed to match that of the switch console port.

Step 3 Load any helper files:

switch: load_helper 

Step 4 Display the contents of flash memory:

switch: dir flash: 

The switch file system appears:

Directory of flash: 
   13  drwx         192   Mar 01 1993 22:30:48  c3750-ipservices-mz-122-25.SEB 
   11  -rwx        5825   Mar 01 1993 22:31:59  config.text 
   18  -rwx         720   Mar 01 1993 02:21:30  vlan.dat 

16128000 bytes total (10003456 bytes free)  

Step 5 Rename the configuration file to config.text.old.

This file contains the password definition.

switch: rename flash:config.text flash:config.text.old 

Step 6 Boot the system:

switch: boot 

You are prompted to start the setup program. Enter N at the prompt:

Continue with the configuration dialog? [yes/no]: N 

Step 7 At the switch prompt, enter privileged EXEC mode:

Switch> enable 

Step 8 Rename the configuration file to its original name:

Switch# rename flash:config.text.old flash:config.text  


Note Before continuing to Step 9, power on any connected stack members and wait until they have completely initialized. Failure to follow this step can result in a lost configuration depending on how your switch is set up.


Step 9 Copy the configuration file into memory:

Switch# copy flash:config.text system:running-config  Source filename [config.text]?  Destination filename [running-config]? 

Press Return in response to the confirmation prompts.

The configuration file is now reloaded, and you can change the password.

Step 10 Enter global configuration mode:

Switch# configure terminal 

Step 11 Change the password:

Switch (config)# enable secret password 

The secret password can be from 1 to 25 alphanumeric characters, can start with a number, is case sensitive, and allows spaces but ignores leading spaces.

Step 12 Return to privileged EXEC mode:

Switch (config)# exit  Switch#  

Step 13 Write the running configuration to the startup configuration file:

Switch# copy running-config startup-config 

The new password is now in the startup configuration.


Note This procedure is likely to leave your switch virtual interface in a shutdown state. You can see which interface is in this state by entering the show running-config privileged EXEC command. To re-enable the interface, enter the interface vlan vlan-id global configuration command, and specify the VLAN ID of the shutdown interface. With the switch in interface configuration mode, enter the no shutdown command.


Step 14 Reload the switch stack:

Switch# reload


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_sec/configuration/guide/swtrbl.html#wp1021182

Backup IOS switch Catalyst

switch#sh flash

Directory of flash:/

2 -rwx 99 Feb 24 2005 11:16:03 -05:00 private-config.text
3 -rwx 8149 Feb 24 2005 11:16:03 -05:00 config.text
4 -rwx 804 Jun 10 2004 18:45:09 -04:00 vlan.dat
6 -rwx 342 Jun 10 2004 11:36:32 -04:00 system_env_vars
24 drwx 192 Jun 10 2004 11:36:23 -04:00 c3550-i5q3l2-mz.121-20.EA2
7 -rwx 18 Jun 10 2004 11:36:32 -04:00 env_vars

15998976 bytes total (8269312 bytes free)

c3550-i5q3l2-mz.121-20.EA2 is the directory that the IOS file is in

This gives you the IOS file name in the directory

switch#cd flash:/c3550-i5q3l2-mz.121-20.EA2
switch#sh flash

Directory of flash:/c3550-i5q3l2-mz.121-20.EA2/

25 drwx 2688 Jun 10 2004 11:34:50 -04:00 html
107 -rwx 4219426 Jun 10 2004 11:36:23 -04:00 c3550-i5q3l2-mz.121-20.EA2.bin
108 -rwx 252 Jun 10 2004 11:36:23 -04:00 info

15998976 bytes total (8269312 bytes free)

Next copy the IOS to the tftp server

switch#copy flash tftp
Source filename [flash:/c3550-i5q3l2-mz.121-20.EA2.bin]? flash:/c3550-i5q3l2-mz.121-20.EA2/c3550-i5q3l2-mz.121-20.EA2.bin
Address or name of remote host []? 10.1.1.1
Destination filename [/c3550-i5q3l2-mz.121-20.EA2/c3550-i5q3l2-mz.121-20.EA2.bin]? c3550-i5q3l2-mz.121-20.EA2.bin

February 23, 2011

Using a TFTP Server to Upgrade a Cisco IOS Image

Using a TFTP Server to Upgrade a Cisco IOS Image

Topology Diagram





Learning Objectives


Verify the current Cisco IOS image.


Configure access to the TFTP server.


Upload a new Cisco IOS image.


Configure the boot system command.


Test the new Cisco IOS image.


Introduction

In this activity, you will configure access to a TFTP server and upload a newer, more advanced Cisco IOS image. Although Packet Tracer simulates upgrading the Cisco IOS image on a router, it does not simulate backing up a Cisco IOS image to the TFTP server. In addition, although the image you are upgrading to is more advanced, this Packet Tracer simulation will not reflect the upgrade by enabling more advanced commands. The same Packet Tracer command set will still be in effect.

Task 1: Verify the Current Cisco IOS Image

Step 1. Use the show version command to verify the image currently loaded in RAM.

R2#show version

Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Mon 15-May-06 14:54 by pt_team

ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)

System returned to ROM by power-on

System image file is "flash:c1841-ipbase-mz.123-14.T7.bin"

The image currently loaded in RAM does not support SSH or many other advanced features.


Step 2. Use the show flash command to verify any images currently available in flash.

R2#show flash

System flash directory:

File Length Name/status

1 13832032 c1841-ipbase-mz.123-14.T7.bin

[13832032 bytes used, 18682016 available, 32514048 total]

32768K bytes of processor board System flash (Read/Write)

Only one Cisco IOS image is available. Before you can use SSH and additional security features, you must upgrade the image to a more advanced version.

Task 2: Configure Access to the TFTP Server

R2 needs to establish a connection to a TFTP server that has the Cisco IOS image you need.

Step 1. Connect R2 and the TFTP server.

Refer to the topology diagram for the correct interface.

Step 2. Configure R2 with an IP address.

Refer to the topology diagram for the correct IP addressing.

Step 3. Configure the TFTP server with IP addressing and a default gateway.

Refer to the topology diagram for the correct IP addressing.

Step 4. Test connectivity.

R2 should be able to successfully ping the TFTP server. If not, check your cabling and addressing.

Step 5. Check results.

Your completion percentage should be 80%. If not, click Check Results to see which required components are not yet completed.

Task 3: Upload a New Cisco IOS Image

Step 1. Check the TFTP server for Cisco IOS images.

Click TFTP Server and then the Config tab. Next, click the TFTP tab. Notice that there are several images available. You will upload the c1841-ipbasek9-mz.124-12.bin image to R2.

Step 2. Upload the c1841-ipbasek9-mz.124-12.bin image to R2.


On R2, begin the upload process with the copy tftp flash command.


Enter the IP address for TFTP Server.


Enter the entire filename of the Cisco IOS image.


R2#copy tftp flash

Address or name of remote host []? 192.168.20.254

Source filename []? c1841-ipbasek9-mz.124-12.bin

Destination filename [c1841-ipbasek9-mz.124-12.bin]? Enter

Accessing tftp://192.168.20.254/c1841-ipbasek9-mz.124-12.bin...

Loading c1841-ipbasek9-mz.124-12.bin from 192.168.20.254: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 16599160 bytes]

16599160 bytes copied in 13.047 secs (284682 bytes/sec)

R2#

Step 3. Verify that the new image is now in flash.

R2#show flash

System flash directory:

File Length Name/status

1 13832032 c1841-ipbase-mz.123-14.T7.bin

2 16599160 c1841-ipbasek9-mz.124-12.bin

[30431192 bytes used, 2082856 available, 32514048 total]

32768K bytes of processor board System flash (Read/Write)

R2#

Step 4. Check results.

Your completion percentage should be 90%. If not, click Check Results to see which required components are not yet completed.

Task 4: Configure the boot system Command

By default, the router bootup sequence loads the first Cisco IOS image listed in flash. One way to make sure that the router loads the new image is to configure the boot system flash command. On R2, enter the following command:

R2(config)#boot system flash c1841-ipbasek9-mz.124-12.bin

This command is now part of the running configuration. However, the running configuration must also be saved to NVRAM; otherwise, the configuration is overwritten the next time you reload the router.

R2(config)#end

R2#copy running-config startup-config

Your completion percentage should be 100%. If not, click Check Results to see which required components are not yet completed.

Task 5: Test the New Image

Reload R2 and wait for it to reboot. When the router reloads, verify that the new image is in RAM with the show version command.

R2#reload

Proceed with reload? [confirm][Enter]

%SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.

R2>show version

Cisco IOS Software, 1841 Software (C1841-IPBASEK9-M), Version 12.4(12), RELEASE SOFTWARE (fc1)

Compiled Mon 15-May-06 14:54 by pt_team

ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)

System returned to ROM by power-on

System image file is "flash:c1841-ipbasek9-mz.124-12.bin"


link: http://www.thecenterforadvancedlearning.org/cisco/semester_4/courses/en1400000000/en1404000000/en1404050000/en1404050400/en1404050403/E4_PTAct_4_5_4.pdf

February 20, 2011

Cara mengetahu driver pc yg hilang

Setelah instal ulang Pc biasanya tidak semua driver ke detek .nah untuk mengetahui driver yg gak kedetek tidak perlu kita bongkar pc nya untuk tahu merk dan id devicenya.
caranya:
1. buka start-program-accesoris-system tools-system information.


2. masuk ke component - problem devices
3. di sebelah kanan akan muncul apasaja yang tidak terdeteksi,
4. untuk tau vendornya cari kode 4 digit contoh 'ven_1969' n klo device id 'dev_1048'
5. buka http://www.pcidatabase.com/
6. selanjutnya masukan kode diatas di situs tsb..nanti akan ketahuan apa vendor dan device idnya
7. setelah tau tau vendor n device id nya cari disitus vendor tsb.

moga bermanfaat

CNAPUI2010





Tentang saya

Sebenarnya saya kurang begitu suka menulis.blog ini saya buat dgn tujuan membuat catatan karena saya termasuk orang yg mudah lupa.
Bilamana tulisan ini berguna buat orang lain ya Alkhamdullilah.
Kebanyakan blog saya ini berisi tentang cisco (td bermaksud promosi ) karena saya telah menyelesaikan program CNAP di UI th 2010..cma belum sertifikasi internasional sichh hehe..(lum ada duit n lom pede nih)..
saya bisa di kontak lewat : setyo.hermanto@yahoo.co.id
setyo.hermanto@gmail.com



salam

January 30, 2011

Konfigurasi Static to Rip v2










router 0

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interf
Router(config)#interface ser
Router(config)#interface serial 0/0/0
Router(config-if)#ip add
Router(config-if)#clock rate 56000
Router(config-if)#no sh
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.1 255.255.255.252
Router(config-if)#exit
Router(config)#
Router(config)#interface fas
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router r
Router(config-router)#ver
Router(config-router)#version 2
Router(config-router)#net
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.0.0
Router(config-router)#


router 1

Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#in
Router(config)#interface fas
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#inter
Router(config)#interface ser
Router(config)#interface serial 0/0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.2 255.255.255.252
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/1/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.5 255.255.255.252
Router(config-if)#no sh
Router(config)#router r
Router(config-router)#ver
Router(config-router)#version 2
Router(config-router)#net
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.1.0
Router(config-router)#redistribute static
Router(config-router)#exit
Router(config)#ip route 192.168.3.0 255.255.255.0 Serial0/1/0


Router 2

Router>
Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#in
Router(config)#interface ser
Router(config)#interface serial 0/0/0
Router(config-if)#clo
Router(config-if)#clock
Router(config-if)#clock rate
Router(config-if)#clock rate 56000
Router(config-if)#no sh
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#ip ad
Router(config-if)#ip address 192.168.2.6 255.255.255.252
Router(config-if)#ex
Router(config)#in
Router(config)#interface fas
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 192.168.0.0 255.255.255.0 serial 0/0/0
Router(config)#exit

Tes Pc 0 ke PC 1
PC>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time=93ms TTL=126
Reply from 192.168.1.2: bytes=32 time=94ms TTL=126
Reply from 192.168.1.2: bytes=32 time=63ms TTL=126
Reply from 192.168.1.2: bytes=32 time=81ms TTL=126

Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 63ms, Maximum = 94ms, Average = 82ms

Tes PC0 to PC 2
PC>ping 192.168.3.2

Pinging 192.168.3.2 with 32 bytes of data:

Reply from 192.168.3.2: bytes=32 time=109ms TTL=125
Reply from 192.168.3.2: bytes=32 time=109ms TTL=125
Reply from 192.168.3.2: bytes=32 time=109ms TTL=125
Reply from 192.168.3.2: bytes=32 time=125ms TTL=125

Ping statistics for 192.168.3.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 109ms, Maximum = 125ms, Average = 113ms

Konfigurasi Ripv2 route

router 0
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interf
Router(config)#interface ser
Router(config)#interface serial 0/0/0
Router(config-if)#ip add
Router(config-if)#clock rate 56000
Router(config-if)#no sh
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.1 255.255.255.252
Router(config-if)#exit
Router(config)#
Router(config)#interface fas
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router r
Router(config-router)#ver
Router(config-router)#version 2
Router(config-router)#net
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168..0
^
% Invalid input detected at '^' marker.

Router(config-router)#network 192.168.0.0
Router(config-router)#

router 1



Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#in
Router(config)#interface fas
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#inter
Router(config)#interface ser
Router(config)#interface serial 0/0/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.2 255.255.255.252
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router r
Router(config-router)#ver
Router(config-router)#version 2
Router(config-router)#net
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.1.0
Router(config-router)#exit
Router(config)#


sekarang ping dari Pc 0 ke Pc 1PC>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time=94ms TTL=126
Reply from 192.168.1.2: bytes=32 time=93ms TTL=126
Reply from 192.168.1.2: bytes=32 time=94ms TTL=126
Reply from 192.168.1.2: bytes=32 time=93ms TTL=126

Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 93ms, Maximum = 94ms, Average = 93ms

Perbedaan Rip v1 dgn Rip v2 adalah Rip v2 support VLSM.


Konfigurasi static route

Router 0 konfigurasi spt dbawah ini:
Router#sh run
Building configuration...

Current configuration : 593 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.252
clock rate 56000
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 Serial0/0/0
!

!
line con 0
line vty 0 4
login
!
!
end

Router 1 konfigurasi spt di bawah ini:
sh run
Building configuration...

Current configuration : 575 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.2.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.0.0 255.255.255.0 Serial0/0/0
!
line con 0
line vty 0 4
login
!
!
!
end

lalu coba tes :
PC>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time=94ms TTL=126
Reply from 192.168.1.2: bytes=32 time=94ms TTL=126
Reply from 192.168.1.2: bytes=32 time=93ms TTL=126
Reply from 192.168.1.2: bytes=32 time=94ms TTL=126

Static route berhasil..

January 26, 2011

Blok ip ganjil atu genap ACL

Blok IP ganji ataupun genap dari network 192.168.0.0 255.255.255.0

If it is 0, the IP address will be Even

-If it is 1, the IP address will be Odd

192.168.1.00000001 = 192.168.1.1 – odd

192.168.1.00000011 = 192.168.1.3 – odd

192.168.1.00000010 = 192.168.1.2 even

192.168.1.00000100 = 192.168.1.4 even

FOR Even Networks

The IP address will be 192.168.1.0

With the wild card mask as 0.0.0.254

254 = 11111110

Here, 0 means DO CARE of the last bit in IP address (must be ZERO)

For Odd Networks

The IP address will be 192.168.1.1

With the wild card mask as 0.0.0.254

254 = 11111110

Here, 0 means DO CARE of the last bit in IP address (must be ONE)

(source ciscotips.wordpress.com)

January 21, 2011

Setting SSH router Cisco




Cara setting SSH di Router cisco (pake GNS3)
1. Masuk global config
2. Configure hostname dan interfacenya
3. username dan password
4. Ip domain name contoh.com
5. Crypto key generate rsa
6. Masuk line vty 0 4
7. Transport input ssh
8. Login local

Router satunya juga di seeting spt diatas.

Cara ngetes SSH:
ssh username ip address

January 20, 2011

Reset Password Cisco router

Cara reset password Cisco router seri 2500 ke atas:
1. Matikan tombol router terus nyalakan lagi dan tekan ctrl+shift + break.
2. Akan masuk ke ROMMON...( Rommon> )
3. Ketik confreg 0x02142 trs tekan enter
4. Masih di Romon ketik reset trs enter
5. Router akan reboot dan seperti biasa pilih no:
6. Anda sudah masuk ke router dan bisa ubah password
7. jangan lupa copy run-start
8. Masuk ke global config dan ketik 'configuration-register 0x2102

Untuk yang model sebelum seri 2500 ke bawah beda lagi:
1. Sama spti diatas masuk ke Rommon
2. Ketik 'o/r enter
3. Ketik 'i' (tanpa tanda '') enter
4.selebihnya sama dengan diatas.
Ĭ